import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "192\\.168\\.(1?[0-9][0-9]?|2[0-4][0-9]|25[0-5])\\.([2-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-4])[[:space:]]";
final String string = "eth0 Link encap:Ethernet HWaddr 09:00:12:90:e3:e5 \n"
+ " inet addr:192.168.1.29 Bcast:192.168.1.255 Mask:255.255.255.0\n"
+ " inet6 addr: fe80::a00:27ff:fe70:e3f5/64 Scope:Link\n"
+ " UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1\n"
+ " RX packets:54071 errors:1 dropped:0 overruns:0 frame:0\n"
+ " TX packets:48515 errors:0 dropped:0 overruns:0 carrier:0\n"
+ " collisions:0 txqueuelen:1000 \n"
+ " RX bytes:22009423 (20.9 MiB) TX bytes:25690847 (24.5 MiB)\n"
+ " Interrupt:10 Base address:0xd020 \n"
+ "lo Link encap:Local Loopback \n"
+ " inet addr:127.0.0.1 Mask:255.0.0.0\n"
+ " inet6 addr: ::1/128 Scope:Host\n"
+ " UP LOOPBACK RUNNING MTU:16436 Metric:1\n"
+ " RX packets:83 errors:0 dropped:0 overruns:0 frame:0\n"
+ " TX packets:83 errors:0 dropped:0 overruns:0 carrier:0\n"
+ " collisions:0 txqueuelen:0 \n"
+ " RX bytes:7766 (7.5 KiB) TX bytes:7766 (7.5 KiB)\n"
+ "wlan0 Link encap:Ethernet HWaddr 58:a2:c2:93:27:36 \n"
+ " inet addr:192.168.1.64 Bcast:192.168.2.255 Mask:255.255.255.0\n"
+ " inet6 addr: fe80::6aa3:c4ff:fe93:4746/64 Scope:Link\n"
+ " UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1\n"
+ " RX packets:436968 errors:0 dropped:0 overruns:0 frame:0\n"
+ " TX packets:364103 errors:0 dropped:0 overruns:0 carrier:0\n"
+ " collisions:0 txqueuelen:1000 \n"
+ " RX bytes:115886055 (110.5 MiB) TX bytes:83286188 (79.4 MiB)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}