using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""(?<last_name>[^ \""]+)\s|\""(?<first_name>[^ \""]+)";
string input = @"""Liam John"" ""Grayson Roy"" ""Olivia"" ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}