#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:"pin"\s*:\s*"|"secretCode"\s*:\s*"|<pin>|<secretCode>))[0-9]{4}(?:("|<\/pin>|<\/secretCode>))"
Local $sString = "{" & @CRLF & _
""pin":"0000"," & @CRLF & _
""secretCode":"0000"" & @CRLF & _
"}" & @CRLF & _
"<xml>" & @CRLF & _
"<pin>0000</pin>" & @CRLF & _
"<secretCode>0000</secretCode>" & @CRLF & _
"</xml>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")