import re
regex = re.compile(r"^(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)$", flags=re.MULTILINE)
test_str = ("\n"
"0.0.0.1\n"
"0.0.0.2\n"
"0.0.0.3\n"
"10.10.10.10\n"
"255.255.255.254\n"
"172.0.0.1\n"
"17.254.255.1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")