re = /^(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)$/m
str = '
0.0.0.1
0.0.0.2
0.0.0.3
10.10.10.10
255.255.255.254
172.0.0.1
17.254.255.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end