package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){((?:[^{}]++|(?R))*)}`)
var str = `#242424##{FFFFF}{2{GGFFFGF}{BBBBB}}{GGGG}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}