const regex = /0\d{2}-\d{8}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0\\d{2}-\\d{8}', 'gm')
const str = `012-12345678
这个表达式的可以简单的匹配一个带区号的座机号码
0:区号要以0开头
\\d{2}: 两位数字
-:连接符
\\d{8}:8位数字`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}