$re = '/0\d{2}-\d{8}/m';
$str = '012-12345678
这个表达式的可以简单的匹配一个带区号的座机号码
0:区号要以0开头
\\d{2}: 两位数字
-:连接符
\\d{8}:8位数字';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);