const regex = new RegExp('\\([^,()]+\\K,', 'gm')
const str = `colAVal, (colBVal_1, colBVal_2), colCVal
a, b, c
1, 2, 3
(1,2),3,4`;
const subst = `@`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);