import Foundation
let pattern = #"\([^,()]+\K,"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
colAVal, (colBVal_1, colBVal_2), colCVal
a, b, c
1, 2, 3
(1,2),3,4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"@"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)