package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$\d+\.\d+(*SKIP)(*FAIL)|\$\d+`)
var str = `
Something $122.30 $45 $1.111
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}