$re = '~\$\d+\.\d+(*SKIP)(*FAIL)|\$\d+~m';
$str = '
Something $122.30 $45 $1.111
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);