package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Iraq[^i]`)
var str = `Iraqi freedom.
Iraq is a country.
Iraq.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}