$re = '/\/portal\/(?!static\/).*/m';
$str = '/portal/static123
/portal/test
/portal/test/123
/portal/static/doesntmatch
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);