#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\/\*A-Z0-9_\s]*(?=\{)\{RSTART_(?=(([A-Z0-9]{6}[0-9]))).+(?=(RSTART_(?=(([A-Z0-9]{6}[0-9]))))).+$"
Local $sString = " {RSTART_IDT1S03, RSTART_IDT1S03},"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")