package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)routing number[:]*\s*(\d{9})(?:[^\d]|$)`)
var str = `routing no. 103000677
routing no 103000677
routing no 304 982 400
routing # 253279471nmls
routing number:231176855
routing number: 101109923lost `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}