import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "routing number[:]*\\s*(\\d{9})(?:[^\\d]|$)";
final String string = "routing no. 103000677\n"
+ "routing no 103000677\n"
+ "routing no 304 982 400\n"
+ "routing # 253279471nmls\n"
+ "routing number:231176855\n"
+ "routing number: 101109923lost ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}