use strict;
my $str = '// good
// 1. group case
2.11.1111
9.11.1111
02.11.1111
09.11.1111
19.11.1111
29.11.1111
30.11.1111
31.11.1111
0.11.1111
00.11.1111
32.11.1111
// 2. group case
11.2.1111
11.9.1111
11.02.1111
11.09.1111
11.10.1111
11.12.1111
11.0.1111
11.00.1111
11.13.1111
// good input, bad date (needs script to process date)';
my $regex = qr/^((([1-9])|([0][1-9])|([1-2]\d)|([3][01]))\.(([1-9])|([0][1-9])|([1][012]))\.\d{4})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}