import Foundation
let pattern = #"^((([1-9])|([0][1-9])|([1-2]\d)|([3][01]))\.(([1-9])|([0][1-9])|([1][012]))\.\d{4})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// good
// 1. group case
2.11.1111
9.11.1111
02.11.1111
09.11.1111
19.11.1111
29.11.1111
30.11.1111
31.11.1111
0.11.1111
00.11.1111
32.11.1111
// 2. group case
11.2.1111
11.9.1111
11.02.1111
11.09.1111
11.10.1111
11.12.1111
11.0.1111
11.00.1111
11.13.1111
// good input, bad date (needs script to process date)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)