package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|\{)(\s*?)(act)`)
var str = `act something
{act something
{ act something`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}