$re = '/(^|\{)(\s*?)(act)/';
$str = 'act something
{act something
{ act something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);