package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:1[0-4]\d{2})|(?:\d{1,3}))(?:(?:lb)?$|(?:lb(1[0-5]|[1-9])(?:oz)?)$)`)
var str = `1500`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}