// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:1[0-4]\d{2})|(?:\d{1,3}))(?:(?:lb)?$|(?:lb(1[0-5]|[1-9])(?:oz)?)$)").unwrap();
let string = "1500";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}