import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(([^0-9\\r\\n]*\\d){3}))(?!(.*-){2})(?!(.*\\/){2}).*$";
final String string = "02ABU-D9435\n"
+ "13DFC\n"
+ "1123451\n"
+ "03323456782\n"
+ "ADS7124536768\n"
+ "03SDFA9433/0\n"
+ "03SDFA9433/\n"
+ "03SDFA9433/1\n"
+ "A41B03423523\n"
+ "O4AGFC4430\n"
+ "01/01/2018\n"
+ "AA-AA\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}