# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+\..+?\\/.+?\\/).+/$1/gm;t' <<< "http://www.example.com/part1/part2/part3/part4
http://www.example.org/part1/part2/part3/part4
http://subdomain.example.org/part1/part2/part3/part4
http://subdomain1.subdomain2.example.org/part1/part2/part3/part4"