$re = '/(.+\..+?\/.+?\/).+/m';
$str = 'http://www.example.com/part1/part2/part3/part4
http://www.example.org/part1/part2/part3/part4
http://subdomain.example.org/part1/part2/part3/part4
http://subdomain1.subdomain2.example.org/part1/part2/part3/part4';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;