#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\[\h*\d[\h\d]*]|\(\h*\d[\h\d]*\)|{\h*\d[\h\d]*})\h*(*SKIP)(*F)|[^#\n]"
Local $sString = "# (1296) {20} [529] [1496] [411]" & @CRLF & _
"# (MONDAY ) (1296)" & @CRLF & _
"# (646) {20} (BEACH 7) [20 Mtrs] { 03 Foot }" & @CRLF & _
"# {19} [455] [721] (1296) (SUNDAY ) [2741] (MONDAY (WEDNESDAY {20}" & @CRLF & _
"# {19} (1296)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)