const regex = /(?:\[\h*\d[\h\d]*]|\(\h*\d[\h\d]*\)|{\h*\d[\h\d]*})\h*(*SKIP)(*F)|[^#\n]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\[\\h*\\d[\\h\\d]*]|\\(\\h*\\d[\\h\\d]*\\)|{\\h*\\d[\\h\\d]*})\\h*(*SKIP)(*F)|[^#\\n]', 'gm')
const str = `# (1296) {20} [529] [1496] [411]
# (MONDAY ) (1296)
# (646) {20} (BEACH 7) [20 Mtrs] { 03 Foot }
# {19} [455] [721] (1296) (SUNDAY ) [2741] (MONDAY (WEDNESDAY {20}
# {19} (1296)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);