package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)(?:\s*cm\s+[xX])`)
var str = `23 cm
43 1/2 cm
20cm
15 cm x 30 cm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}