import re
regex = re.compile(r"^(\d+)(?:\s*cm\s+[xX])", flags=re.MULTILINE)
test_str = ("23 cm\n"
"43 1/2 cm\n\n"
"20cm\n"
"15 cm x 30 cm")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")