package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[,]?[\s]?([^,\n]+)`)
var str = `zonder fenoxyethanol, fenoxyethanolvrij, 0\% fenoxyethanol, bevat geen fenoxyethanol
zonder octocryleen, vrij van octocryleen, octocryleen-vrij, 0\% octocryleen, bevat geen octocryleen
zonder aluminiumzouten, vrij van aluminiumzouten, 0\% aluminiumzouten, bevat geen aluminiumzouten
zonder tolueen, tolueenvrij, 0 \% tolueen, bevat geen tolueen
zonder zeep, zeepvrij, bevat geen zeep, 0 \% zeep
zonder surfactant(en), bevat geen surfactant(en), vrij van surfactant(en), 0\% surfactant(en); zonder opervlakte-actieve stof(fen), bevat geen oppervlakte-actieve stof(fen), vrij van oppervlakte-actieve stof(fen), 0\% oppervlakte-actieve stof(fen)/zonder tensio-actieve stof(fen), vrij van tensio-actieve stof(fen), bevat geen tensio-actieve stoffen; zonder grensvlakactieve stof(fen), vrij van grensvlakactieve stof(fen), bevat geen grensvlakactieve stof(fen), 0\% grensvlakactieve stoffen; zonder tenside(n), bevat geen tenside(n), vrij van tenside(n), 0\% tenside(n)
zonder sulfaat, 0\% sulfaat, sulfaatvrij, bevat geen sulfaten
zonder kleurstoffen, 0 \% kleurstoffen, kleurstofvrij, vrij van kleurstoffen, bevat geen kleurstoffen
zonder zout, zoutvrij, vrij van zout(en), 0\% zout(en), bevat geen zout(en)
zonder minerale oliën, vrij van minerale oliën, 0\% minerale oliën, bevat geen minerale oliën
zonder olie, bevat geen olie, olie-vrij
zonder lanoline, 0\% lanoline, bevat geen lanoline, lanolinevrij, vrij van lanoline
zonder nano/nanoparticulen, vrij van nano/nanoparticulen , bevat geen nano/nanoparticulen, 0\% nano/nanoparticulen
zonder GGO, bevat geen GGO, vrij van GGO, GGO-vrij; genetisch gemodificeerd organisme`
var substitution = "OR t LIKE '%$1%'\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}