const regex = /[A-Za-z0-9]+@((gmail)+)*\.(com|org|edu|gg)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z0-9]+@((gmail)+)*\\.(com|org|edu|gg)', '')
const str = `qfkqf@gmailgmailgmailgmailgmailgmailgmailgmailgmailgmailgmailgmailgmailgmailgmail@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}