$re = '/[A-Za-z0-9]+@((gmail)+)*\.(com|org|edu|gg)/';
$str = 'qfkqf@gmailgmailgmailgmailgmailgmailgmailgmailgmailgmailgmailgmailgmailgmailgmail@gmail.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);