package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{11}$`)
var str = `18100000001
+8618100000001
+86 18100000001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}