$re = '/^[0-9]{11}$/m';
$str = '18100000001
+8618100000001
+86 18100000001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);