const regex = new RegExp('^....z$', '')
const str = `reedz
#Write a regular expression which would find all words which have exactly 5 letters in them, of which the last letter is a "z".`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}