using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CURDEPTH\([^0].*\)";
string input = @"CURDEPTH(101)
CURDEPTH(1034544)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}