$re = '/CURDEPTH\([^0].*\)/m';
$str = 'CURDEPTH(101)
CURDEPTH(1034544)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);