re = /(?<!\w)HIPAA(?!\w)|(?<!\w)ERP\(2.0\)(?!\w)/m
str = 'HIPAA and ERP
HIPAA and ERP(2.0)
HIPAASTOL and ERP(2.0)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end