$re = '/^(?!-)[a-zA-Z0-9:#,()\/.-]+$/m';
$str = 'A
9
A9
Aa9
/.----,#23423etfERGRG
-e
----';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);