re = /^(?!-)[a-zA-Z0-9:#,()\/.-]+$/m
str = 'A
9
A9
Aa9
/.----,#23423etfERGRG
-e
----'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end