package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(-?\d+)`)
var str = `-10-0
20-30
-60-50
0-10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}