$re = '/^(-?\d+)/m';
$str = '-10-0
20-30
-60-50
0-10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);