import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\{%\\ for.+?%\\}\n"
+ "|\n"
+ "\\G(?!\\A)\n"
+ ")\n"
+ "(?s:(?!\\{%).)*?\\K\n"
+ "\\{\\{\\s*(?P<variable>.+?)\\s*\\}\\}";
final String string = "{% for user in users %}\n"
+ " Hello, {{ user.name }}, you are {{ user.age }} {{ user.name }}\n"
+ "ssssssssssssssssssssss {{ user.name }}\n"
+ "sdsddddddddddddddddddddddddddddd\n"
+ "{% endfor %}\n\n"
+ "{% for dog in dogs %}\n"
+ " Your dog is {{ dog.age }} and likes {{ dog.food }}.\n"
+ "{% endfor %}\n"
+ "wwww\n"
+ "{{ user.name }}";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}