# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:{%\ for.+?%}
|
\G(?!\A)
)
(?s:(?!{%).)*?\K
{{\s*(?P<variable>.+?)\s*}}
"""
test_str = ("{% for user in users %}\n"
" Hello, {{ user.name }}, you are {{ user.age }} {{ user.name }}\n"
"ssssssssssssssssssssss {{ user.name }}\n"
"sdsddddddddddddddddddddddddddddd\n"
"{% endfor %}\n\n"
"{% for dog in dogs %}\n"
" Your dog is {{ dog.age }} and likes {{ dog.food }}.\n"
"{% endfor %}\n"
"wwww\n"
"{{ user.name }}")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.