$re = '/(?:\'([^\']*[\'s]?)\'|\"([^\"]*)\")|[^\s,<>=!]+|(?:,|[<>!]?=|<>?|>)/m';
$str = 'age<21,length>10,height<>10,width!=100,name=\'Emma Einarsson\' or it can be words time>=10,clouds<=4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);