re = /(?:\'([^\']*[\'s]?)\'|\"([^\"]*)\")|[^\s,<>=!]+|(?:,|[<>!]?=|<>?|>)/m
str = 'age<21,length>10,height<>10,width!=100,name=\'Emma Einarsson\' or it can be words time>=10,clouds<=4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end