const regex = /^(\d+)A/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)A', 'gm')
const str = `74A76B217C
8B7A1742B
8123A9A8B`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}