$re = '/^(\d+)A/m';
$str = '74A76B217C
8B7A1742B
8123A9A8B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);