package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^( \t]+(?:[ \t]+[^( \t]+)*`)
var str = `Test Tester AndTest (2552)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}